Go Pro Sign Up Login
0 days 0 hrs 0 min 0 sec

Summer Sale

50% off Level Up Pro until you unsubscribe.
Get access to ALL 128 courses on Level Up Tutorials

This is your last chance to get Level Up Pro for $145/year.

or Learn More
Moon Moon

Buy Now and unlock this series

$

49

.99

yours forever

Become a Pro and unlock everything

$

24

.99

per month

The $lib Directory

In this video, we will talk about the mysterious $lib directory.

Downloads

Become a pro to download code and videos

Comments

User avatar

Spenser

about 1 year ago [edited]

About 2 minutes in I'm having issues with importing the Header component. I have everything the exact same as Scott and yet it refuses to show up. No errors of any kind. Interestingly I can put the header.svelte in '.svelte-kit/dev/components' and it imports just fine from there but frankly I'd rather have it in the src folder with that nice alias. So I'm not sure if something changed since the tut was made (still in beta at this time). Pulling my hair out over this one. As Gandhi once said: "this sh*t is bananas. B-A-N-A-N-A-S". If anyone had this problem's solution and want to share it would be appreciated and if I find a fix I'll follow up.

EDIT: Ok plot twist. Its actually there but svelte is giving it display: none for some reason.

EDIT: Ok for those of you following along at home we have reached a conclusion. The problem was I have the IQ of a butternut squash. I wrapped the HTML in the component in the < head > instead of < header >. I shall now quit this industry in shame and wonder the badlands out West as a stranger with no name. This is my cross to bear.

User avatar

Todd

3 months ago

I know this is an old post, but that last EDIT was pretty damn funny

Want to join the conversation?

Become a Pro member today!